Test example: QoS remarking
Setup
information:
Consider the following
setup :
(Ixia)port1--------------Gi1/1(Router)Gi1/2-------------port2 (Ixia)
IP1=11.1.1.100/24 IP2=11.1.2.100/24
GW=11.1.1.1 GW=11.1.2.1
We are going to send traffic from IP1 to IP2 using AF11
When he receives
traffic on Interface Gi1/1 the DUT will remark DSCP value to AF21
af11 Match packets with AF11 dscp (001010)2=(10)10
af21 Match packets with AF21 dscp (010010)2=(18)10
IxNetwork Configuration
Step 1. Create
protocol interfaces
Step2. Create L2-3
Traffic Item
2.1 Add a L2-3
traffic item
2.2 Select the
connected interface as
source/destination endpoints
2.3 On the Paket/
QOS page set IP priority as DiffServ, AF11
2.4 On Flow
Goup page select to create Flow groups based on Source/Destination Endpoint
2.5 On Flow
Tracking page select to track IP-AF PBH values
2.6 On Flow
Tracking page don’t forget to enable
Egress tracking for DSCP
**** All the other
settings are default. Click Finish on
Advance Traffic Wizard and you are good to go.
Step3. Verify results
3.1 Start traffic
3.2 On Statistics window go to Traffic Item Statistics tab. Right-click on Traffic Item and choose
Drill down per IPv4: Assured Forwarding
PBH
3.3 After
performing previous step you are automatically switched to User
Defined Statistics tab
Right-Click on the item and choose to see Egress values
of DSCP
****Right now on
statistics window you will have the intial and also the new marked values of DSCP
DUT Configuration
1 Steps taken to configure the DUT and configuration explain
In order to set a new DSCP value on an interesting
traffic you will need to perform the following steps:
1.
Identify the interesting traffic with an ACL
2. Create a Class Map for matching the Network
Traffic using the ACL
3.
Create a
Policy Map for Applying a QoS Feature to Network Traffic
classified by the class map
4.
Attaching the
Policy Map to an Interface
! Configure IP
address on the interfaces
7606-S(config)#int gi1/1
7606-S(config-if)#ip add 11.1.1.1 255.255.255.0
7606-S(config-if)#exit
7606-S(config)#int gi 1/2
7606-S(config-if)#ip add 11.1.2.1 255.255.255.0
7606-S(config-if)#exit
7606-S(config)#do show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet1/1 11.1.1.1 YES manual up up
GigabitEthernet1/2 11.1.2.1 YES manual up up
! Identify the
interesting traffic (11.1.1.100 -----> 11.1.2.100) with an ACL
7606-S(config)#access-list 101 permit ip host 11.1.1.100
host 11.1.2.100
7606-S(config)#do show access-list
101
Extended
IP access list 101
10
ermit
ip host 11.1.1.100 host 11.1.2.100
! Create a Class Map for
matching the Network Traffic using the ACL
7606-S(config)#class-map cmap-acl-101
7606-S(config-cmap)#match
access-group 101
! Create a Policy
Map for QoS remarking of the Network
Traffic classified by the class map
7606-S(config)#policy-map pmap-acl-101
7606-S(config-pmap)#class cmap-acl-101
7606-S(config-pmap-c)#set dscp af21
7606-S(config)#do show policy-map
pmap-acl-101
Policy Map pmap-acl-101
Class cmap-acl-101
set dscp af21
! Attach the Policy Map to an Interface
7606-S(config)#interface gi 1/1
7606-S(config-if)#service-policy input pmap-acl-101
7606-S(config-if)#do show policy-map
int gi1/1
GigabitEthernet1/1
Service-policy input: pmap-acl-101
class-map: cmap-acl-101 (match-all)
Match: access-group 101
set dscp 18:
Earl in slot 5 :
30121000 bytes
5 minute offered rate 785080 bps
aggregate-forwarded 30121000 bytes
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate
0000 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps
2. Actual DUT configuration
ena
conf ter
int gi1/1
ip add 11.1.1.1 255.255.255.0
exit
int gi 1/2
ip add 11.1.2.1 255.255.255.0
exit
access-list 101 permit ip host 11.1.1.100 host 11.1.2.100
class-map cmap-acl-101
match access-group 101
exit
policy-map pmap-acl-101
class cmap-acl-101
set dscp af21
exit
interface gi 1/1
service-policy input pmap-acl-101
exit